summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKshitij Sisodia <kshitij.sisodia@arm.com>2022-12-29 11:53:23 +0000
committerKshitij Sisodia <kshitij.sisodia@arm.com>2022-12-29 11:56:01 +0000
commitee82c60e5ec707faa5eaa638f397dde7df820dac (patch)
tree84fa7d5da9d4f3fe52391704b517df0529fa4709 /CMakeLists.txt
parent657a54dc7bf8c901a5cf009606d179fe9ae8fd68 (diff)
downloadml-embedded-evaluation-kit-ee82c60e5ec707faa5eaa638f397dde7df820dac.tar.gz
MLECO-3747: Minor changes to Catch2 inclusion
Catch2, included for tests on native target, is now added using FetchContent to download it at configuration stage. Minor improvements added to prevent name clashes if this project is used as a submodule in other projects where Catch2 is already a named dependency/target. Change-Id: I6f0ff02704e54a5c4cefe499ac80d434cf89b463 Signed-off-by: Kshitij Sisodia <kshitij.sisodia@arm.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 91568f8..a36d00d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -15,7 +15,6 @@
# limitations under the License.
#----------------------------------------------------------------------------
cmake_minimum_required(VERSION 3.21.0)
-include(ExternalProject)
# Build in release mode by default
if (NOT CMAKE_BUILD_TYPE STREQUAL Debug)