summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKshitij Sisodia <kshitij.sisodia@arm.com>2021-09-24 14:42:08 +0100
committerKshitij Sisodia <kshitij.sisodia@arm.com>2021-09-24 13:43:22 +0000
commitaa5e1f6c960b8a88f389ba70dd200d6dacd95a03 (patch)
treef05ad3ee9f6eff64a41464f32387d4150fe9363a /CMakeLists.txt
parent864317690dd670a18194e2a95c7c0da573613fa1 (diff)
downloadml-embedded-evaluation-kit-aa5e1f6c960b8a88f389ba70dd200d6dacd95a03.tar.gz
MLECO-2345: Adding dynamic load support for FVPs
With this patch, the generic inference runner use-case can be configured to accept the model tflite file at run-time via the FVP's command line parameters. Same is true for the IFM and the inference results can be dumped out too. NOTE: this change is only for supporting the FVP, the FPGA implementation will not allow additional loading for the changes in this patch to be useful. Change-Id: I1318bd5b0cfb7bb635ced6fe58d22c3e401d2547
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b96d3c4..523bcaa 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -104,7 +104,7 @@ endif()
message(STATUS "Using CMAKE_TOOLCHAIN_FILE: ${CMAKE_TOOLCHAIN_FILE}")
project(arm_ml_embedded_evaluation_kit
- VERSION 21.05
+ VERSION 21.08
DESCRIPTION "ARM ML Embedded Evaluation Kit for MPS3 FPGA and FastModel")
enforce_compiler_version()
@@ -334,6 +334,13 @@ foreach(use_case ${USE_CASES})
PROPERTIES COMPILE_DEFINITIONS
"PRJ_VER_STR=\"${PROJECT_VERSION}\";PRJ_DES_STR=\"${PROJECT_DESCRIPTION}\"")
+ if (DEFINED ${use_case}_COMPILE_DEFS)
+ message(STATUS "Additional compilation flags for ${use_case}: ${${use_case}_COMPILE_DEFS}")
+ set_source_files_properties(${UC_SRC}
+ PROPERTIES COMPILE_DEFINITIONS
+ "${${use_case}_COMPILE_DEFS}")
+ endif()
+
set(UC_LIB_NAME lib${TARGET_NAME})
# Consolidated application static lib: