aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml9
1 files changed, 8 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 2127d1ab..f2c5d60f 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -62,4 +62,11 @@ requires = [
"numpy; python_version>'3.7'",
"setuptools_scm[toml]~=7.1.0"
]
-build-backend = "setuptools.build_meta" \ No newline at end of file
+build-backend = "setuptools.build_meta"
+
+[tool.pytest.ini_options]
+minversion = "6.0"
+addopts = ["-ra", "--showlocals", "--strict-markers", "--strict-config"]
+xfail_strict = true
+filterwarnings = ["error"]
+testpaths = ["ethosu/mlw_codec/test", "ethosu/vela/test"] \ No newline at end of file