aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml9
1 files changed, 9 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index d8cbe661..0c88abb2 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -41,6 +41,15 @@ dependencies = [
]
dynamic = ["readme", "version"]
+[project.optional-dependencies]
+dev = [
+ "pytest",
+ "pytest-cov",
+ "pre-commit",
+ "build",
+ "setuptools_scm[toml]<6"
+]
+
[project.urls]
Homepage = "https://git.mlplatform.org/ml/ethos-u/ethos-u-vela.git/"