aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRickard Bolin <rickard.bolin@arm.com>2022-01-13 12:18:15 +0000
committerRickard Bolin <rickard.bolin@arm.com>2022-02-09 12:27:01 +0000
commita8810553a672407f946cb2e11edab8cd73e2ed43 (patch)
treeae04052db21c1caa5d5a3da84e14a64cfb500086 /setup.py
parent211165a378ccb43696c562fe53e1e1937c75a144 (diff)
downloadethos-u-vela-a8810553a672407f946cb2e11edab8cd73e2ed43.tar.gz
MLBEDSW-5912 - Update to Python 3.8
Change required python version from 3.6 to 3.8 in setup.py and allow any python3 version for black pre-commit linting. Signed-off-by: Rickard Bolin <rickard.bolin@arm.com> Change-Id: I0d8936d92efd5137561834c0de1a3449f9e5f25c
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 68fd28e5..4982bb34 100644
--- a/setup.py
+++ b/setup.py
@@ -77,7 +77,7 @@ setup(
"Operating System :: Microsoft :: Windows :: Windows 10",
"Programming Language :: C",
"Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.6",
+ "Programming Language :: Python :: 3.8",
"Topic :: Scientific/Engineering :: Artificial Intelligence",
"Topic :: Software Development :: Compilers",
],
@@ -89,7 +89,7 @@ setup(
"ethosu.vela.tosa",
"ethosu.mlw_codec",
],
- python_requires="~=3.6",
+ python_requires="~=3.8",
install_requires=[
"flatbuffers==1.12.0",
"numpy>=1.16.6,<=1.19.5",