aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorRickard Bolin <rickard.bolin@arm.com>2023-09-29 12:48:29 +0000
committerRickard Bolin <rickard.bolin@arm.com>2023-10-11 11:07:22 +0000
commitb37a81bfce0c7ae3092e4b3c9f69e08644b84e25 (patch)
tree88f25785f8b978cc57ad4a7b4c83e8cea84033dd /pyproject.toml
parent529b787f0321cbae1878ecb0994c60f670bc7ea1 (diff)
downloadethos-u-vela-b37a81bfce0c7ae3092e4b3c9f69e08644b84e25.tar.gz
MLBEDSW-8111: Update to TensorFlow 2.14
- Update to TensorFlow 2.14 and minimum required Python version to 3.9. - Update version pins on NumPy and FlatBuffers. - Add constraint to Offset attribute of StridedSlice operator Change-Id: I8c7122def963202e5f47e92b62be607935ed05cf Signed-off-by: Rickard Bolin <rickard.bolin@arm.com>
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml10
1 files changed, 4 insertions, 6 deletions
diff --git a/pyproject.toml b/pyproject.toml
index fd4fc2d7..8faa752c 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -17,7 +17,7 @@
[project]
name = "ethos-u-vela"
description = "Neural network model compiler for Arm Ethos-U NPUs"
-requires-python = "~=3.8"
+requires-python = "~=3.9"
authors = [{name = "Arm Ltd", email = "mlg-vela@arm.com"}]
license = {text= "Apache License 2.0"}
classifiers = [
@@ -34,9 +34,8 @@ classifiers = [
]
keywords = ["ethos-u", "vela compiler", "tflite", "npu"]
dependencies = [
- "flatbuffers==23.1.21",
- "numpy<=1.21.3; python_version<='3.7'",
- "numpy; python_version>'3.7'",
+ "flatbuffers==23.5.26",
+ "numpy",
"lxml>=4.5.2"
]
dynamic = ["readme", "version"]
@@ -58,8 +57,7 @@ vela = "ethosu.vela.vela:main"
[build-system]
requires = [
- "numpy<=1.21.3; python_version<='3.7'",
- "numpy; python_version>'3.7'",
+ "numpy",
"setuptools_scm[toml]~=7.1.0"
]
build-backend = "setuptools.build_meta"