aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorRaul Farkas <raul.farkas@arm.com>2023-05-04 12:43:08 +0100
committerRickard Bolin <rickard.bolin@arm.com>2023-05-15 14:15:31 +0000
commit3e7d544134f602eb40ce2a242b6c5f0433fe3543 (patch)
tree7fed589d196b2fa09745fce95972f3c0f5f17b82 /pyproject.toml
parent1c54ac1499da4b1c0de39336c1a9b22e506388b1 (diff)
downloadethos-u-vela-3e7d544134f602eb40ce2a242b6c5f0433fe3543.tar.gz
MLBEDSW-7579: Fix test_build.py test issues
* Fix import order in test_build.py * Fix setup_tools_scm dependency version. Previously the version was restricted to < 6, creating a version restriction on Setuptools library too. Because an older version of Setuptools was used, running test_build.py::test_build_correct_readme_links would generate a UNKNOWN.egg-info directory in the src directory instead of a ethos_u_vela.egg-info directory. Change-Id: I113ca25b23b39d43fa288e6eda16377f4f5b4143 Signed-off-by: Raul Farkas <raul.farkas@arm.com>
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml4
1 files changed, 2 insertions, 2 deletions
diff --git a/pyproject.toml b/pyproject.toml
index fbb72048..2127d1ab 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -47,7 +47,7 @@ dev = [
"pytest-cov",
"pre-commit",
"build",
- "setuptools_scm[toml]<6"
+ "setuptools_scm[toml]~=7.1.0"
]
[project.urls]
@@ -60,6 +60,6 @@ vela = "ethosu.vela.vela:main"
requires = [
"numpy<=1.21.3; python_version<='3.7'",
"numpy; python_version>'3.7'",
- "setuptools_scm[toml]<6"
+ "setuptools_scm[toml]~=7.1.0"
]
build-backend = "setuptools.build_meta" \ No newline at end of file