aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorAlexander Bengtsson <Alexander.Bengtsson@arm.com>2024-05-20 12:55:39 +0200
committerRickard Bolin <rickard.bolin@arm.com>2024-05-21 12:32:11 +0000
commit3955765d971d75571484c8b4ae3c6abc034678ea (patch)
tree06b0b72d72b97ca46d4eff40ed82e380c66ce097 /pyproject.toml
parent722f4bfe837aa33e69b60c1f12e14ab241d1cb0a (diff)
downloadethos-u-vela-3955765d971d75571484c8b4ae3c6abc034678ea.tar.gz
MLBEDSW-9090: Restrict third-party dependencies in pyproject.toml
- Restrict third-party dependency versions based upon compatibility and security concerns. Change-Id: Ic50eb987f012df8c0c46ef0ee51d907b7609edae Signed-off-by: Alexander Bengtsson <Alexander.Bengtsson@arm.com>
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml5
1 files changed, 3 insertions, 2 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 140e8092..a0c35d31 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,4 +1,4 @@
-# SPDX-FileCopyrightText: Copyright 2023 Arm Limited and/or its affiliates <open-source-office@arm.com>
+# SPDX-FileCopyrightText: Copyright 2023-2024 Arm Limited and/or its affiliates <open-source-office@arm.com>
#
# SPDX-License-Identifier: Apache-2.0
#
@@ -33,9 +33,10 @@ classifiers = [
"Topic :: Software Development :: Compilers",
]
keywords = ["ethos-u", "vela compiler", "tflite", "npu"]
+# Third-party dependency versions are restricted based upon compatibility and security concerns.
dependencies = [
"flatbuffers==23.5.26",
- "numpy",
+ "numpy>1.10.0",
"lxml>=4.5.2"
]
dynamic = ["readme", "version"]