aboutsummaryrefslogtreecommitdiff
path: root/mailbox/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'mailbox/CMakeLists.txt')
-rw-r--r--mailbox/CMakeLists.txt9
1 files changed, 4 insertions, 5 deletions
diff --git a/mailbox/CMakeLists.txt b/mailbox/CMakeLists.txt
index 44d8c82..a3bc60f 100644
--- a/mailbox/CMakeLists.txt
+++ b/mailbox/CMakeLists.txt
@@ -1,5 +1,6 @@
#
-# Copyright (c) 2020-2022 Arm Limited.
+# SPDX-FileCopyrightText: Copyright 2020-2023 Arm Limited and/or its affiliates <open-source-office@arm.com>
+# SPDX-License-Identifier: GPL-2.0-only
#
# This program is free software and is provided to you under the terms of the
# GNU General Public License version 2 as published by the Free Software
@@ -15,8 +16,6 @@
# along with this program; if not, you can access it online at
# http://www.gnu.org/licenses/gpl-2.0.html.
#
-# SPDX-License-Identifier: GPL-2.0-only
-#
cmake_minimum_required(VERSION 3.0.2)
@@ -39,7 +38,7 @@ list(TRANSFORM OBJ PREPEND ${CMAKE_CURRENT_SOURCE_DIR}/)
# Build the kernel module
add_custom_target(mailbox-module ALL
COMMAND ${CMAKE_MAKE_PROGRAM} -C ${KDIR}
- M=${CMAKE_CURRENT_SOURCE_DIR} CONFIG_ARM_MHU_V2=m CONFIG_ARM_MHU=m
+ C=2 M=${CMAKE_CURRENT_SOURCE_DIR} CONFIG_ARM_MHU_V2=m CONFIG_ARM_MHU=m
CROSS_COMPILE=${CROSS_COMPILE} ARCH=${ARCH} modules
BYPRODUCTS
${CMAKE_CURRENT_SOURCE_DIR}/arm_mhu.ko
@@ -57,4 +56,4 @@ add_custom_target(mailbox-module ALL
COMMENT "Building arm_mhu.ko arm_mhu_v2.ko"
VERBATIM)
-install(FILES arm_mhu.ko arm_mhu_v2.ko DESTINATION "modules") \ No newline at end of file
+install(FILES arm_mhu.ko arm_mhu_v2.ko DESTINATION "modules")