aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 51f6195..fc2b91f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -40,5 +40,18 @@ if (BUILD_MAILBOX)
add_subdirectory(mailbox)
endif()
+# Build flatbuffers
+unset(PROJECT_VERSION)
+unset(PROJECT_VERSION_MAJOR)
+unset(PROJECT_VERSION_MINOR)
+option(FLATBUFFERS_BUILD_TESTS OFF)
+option(FLATBUFFERS_INSTALL OFF)
+option(FLATBUFFERS_BUILD_FLATC OFF)
+option(FLATBUFFERS_BUILD_FLATHASH OFF)
+add_subdirectory(flatbuffers)
+
+# Build driver library
add_subdirectory(driver_library)
+
+# Build utils
add_subdirectory(utils)