aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorDavide Grohmann <davide.grohmann@arm.com>2022-06-16 17:42:58 +0200
committerDavide Grohmann <davide.grohmann@arm.com>2022-08-29 09:52:15 +0200
commitf03642331f1028bdeba1c24bc5d9bd65b42c7603 (patch)
treed299be4d2f9a3b5292b141d531c1a3824b7424ce /tests/CMakeLists.txt
parent43e7dc41eb7f0701951ac84d82f877be37338d41 (diff)
downloadethos-u-linux-driver-stack-f03642331f1028bdeba1c24bc5d9bd65b42c7603.tar.gz
Add linux_driver_stack tests
Change-Id: I303f1424eb46576847312672f7ed5ac03c05aee1
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt37
1 files changed, 37 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
new file mode 100644
index 0000000..37b7d8b
--- /dev/null
+++ b/tests/CMakeLists.txt
@@ -0,0 +1,37 @@
+#
+# Copyright (c) 2022 Arm Limited.
+#
+# SPDX-License-Identifier: Apache-2.0
+#
+# Licensed under the Apache License, Version 2.0 (the License); you may
+# not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an AS IS BASIS, WITHOUT
+# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+set(CORE_PLATFORM_PATH ${CMAKE_CURRENT_SOURCE_DIR}/../../core_platform)
+
+file(GLOB models LIST_DIRECTORIES true "${CORE_PLATFORM_PATH}/applications/baremetal/models/${ETHOSU_TARGET_NPU_CONFIG}/*")
+
+# Build executable
+foreach(model ${models})
+ get_filename_component(modelname ${model} NAME)
+
+ add_executable(lds_${modelname}_tests "main.cpp")
+
+ target_include_directories(lds_${modelname}_tests PRIVATE
+ ${model})
+
+ # Link agains ethosu library
+ target_link_libraries(lds_${modelname}_tests PRIVATE ethosu)
+
+ # Install target
+ install(TARGETS lds_${modelname}_tests DESTINATION "bin")
+endforeach()