aboutsummaryrefslogtreecommitdiff
path: root/remoteproc/CMakeLists.txt
diff options
context:
space:
mode:
authorPer Åstrand <per.astrand@arm.com>2022-04-06 09:40:11 +0200
committerKristofer Jonsson <kristofer.jonsson@arm.com>2022-06-01 11:17:26 +0000
commit087ea21ebad72c0b5563f04370abc3c6cc9ce8ad (patch)
tree6e5b3e8d99e8cfc7b503f0e0dff6696058b393c2 /remoteproc/CMakeLists.txt
parent7f9a4e36e573eb8e36c61711ce0fa8f885fe2b38 (diff)
downloadethos-u-linux-driver-stack-087ea21ebad72c0b5563f04370abc3c6cc9ce8ad.tar.gz
reset controller driver for corstone1000 ES
Add reset controller driver for external system. The driver is instantiated for each subsystem reset needed to control. Change-Id: I481e56124de30b807858ca3f5fe8f78fc18502ce
Diffstat (limited to 'remoteproc/CMakeLists.txt')
-rw-r--r--remoteproc/CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/remoteproc/CMakeLists.txt b/remoteproc/CMakeLists.txt
index 58c9796..af5f1d1 100644
--- a/remoteproc/CMakeLists.txt
+++ b/remoteproc/CMakeLists.txt
@@ -1,5 +1,5 @@
#
-# Copyright (c) 2020-2021 Arm Limited. All rights reserved.
+# Copyright (c) 2020-2022 Arm Limited. All rights reserved.
#
# This program is free software and is provided to you under the terms of the
# GNU General Public License version 2 as published by the Free Software
@@ -36,7 +36,7 @@ file(GLOB_RECURSE OBJ RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} "*.c")
list(TRANSFORM OBJ REPLACE "^(.*)[.]c" "\\1.o")
list(TRANSFORM OBJ PREPEND ${CMAKE_CURRENT_SOURCE_DIR}/)
-set(MODULES CONFIG_ARM_ETHOSU_RPROC=m CONFIG_ARM_SGM775_ETHOSU_RESET=m CONFIG_ARM_JUNO_FPGA_RESET=m)
+set(MODULES CONFIG_ARM_ETHOSU_RPROC=m CONFIG_ARM_SGM775_ETHOSU_RESET=m CONFIG_ARM_JUNO_FPGA_RESET=m CONFIG_ARM_CORSTONE1000_ES_RESET=m)
# Build the kernel module
add_custom_target(ethosu-remoteproc-module ALL
@@ -54,4 +54,5 @@ add_custom_target(ethosu-remoteproc-module ALL
COMMENT "Building remoteproc modules"
VERBATIM)
-install(FILES ethosu_remoteproc.ko DESTINATION "modules") \ No newline at end of file
+install(FILES ethosu_remoteproc.ko DESTINATION "modules")
+install(FILES corstone1000_es_reset.ko DESTINATION "modules")