aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPer Åstrand <per.astrand@arm.com>2021-04-15 09:47:03 +0200
committerPer Åstrand <per.astrand@arm.com>2021-06-21 11:31:29 +0200
commit87ca5dac68ffd40007e31e11b32980a6d5b7cf83 (patch)
tree4ed216c032c4f6417de9fbedf68c04a8f8020e1b /CMakeLists.txt
parent35ce6c809ccf637c6bb8a00ad14b051b87d9884a (diff)
downloadethos-u-linux-driver-stack-87ca5dac68ffd40007e31e11b32980a6d5b7cf83.tar.gz
Implement reset handler for remoteproc
Use the reset controller driver mechanism to control the Ethos-U subsystem remoteproc driver. Change-Id: If180d5b922f8b1cd245af7f922911c17ecd313a3
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fc2b91f..4711a19 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,5 @@
#
-# Copyright (c) 2020 Arm Limited. All rights reserved.
+# Copyright (c) 2020-2021 Arm Limited. All rights reserved.
#
# SPDX-License-Identifier: Apache-2.0
#
@@ -24,6 +24,7 @@ project("linux_driver_stack" VERSION 1.0)
# Default options
option(BUILD_KERNEL "Build the kernel driver" ON)
option(BUILD_MAILBOX "Build the MHU mailbox kernel module" ON)
+option(BUILD_REMOTEPROC "Build the remoteproc kernel module" ON)
# Add rpath to library directory
set(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/lib")
@@ -40,6 +41,10 @@ if (BUILD_MAILBOX)
add_subdirectory(mailbox)
endif()
+if (BUILD_REMOTEPROC)
+add_subdirectory(remoteproc)
+endif()
+
# Build flatbuffers
unset(PROJECT_VERSION)
unset(PROJECT_VERSION_MAJOR)