aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKristofer Jonsson <kristofer.jonsson@arm.com>2020-08-20 17:25:23 +0200
committerKristofer Jonsson <kristofer.jonsson@arm.com>2020-08-27 13:58:01 +0200
commit116a635581f292cb4882ea1a086f842904f85c3c (patch)
tree96ed12cebd8dbf9f1dc7b8f116be7d528779a2bb /CMakeLists.txt
parentcd13a572fe223fe95cd58c5b55b659885fb7b4cd (diff)
downloadethos-u-linux-driver-stack-116a635581f292cb4882ea1a086f842904f85c3c.tar.gz
Initial commit20.08-rc220.08
Change-Id: I14b6becc908a0ac215769c32ee9c43db192ae6c8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt44
1 files changed, 44 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..51f6195
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,44 @@
+#
+# Copyright (c) 2020 Arm Limited. All rights reserved.
+#
+# SPDX-License-Identifier: Apache-2.0
+#
+# Licensed under the Apache License, Version 2.0 (the License); you may
+# not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an AS IS BASIS, WITHOUT
+# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+cmake_minimum_required(VERSION 3.0.2)
+
+# Set the project name and version
+project("linux_driver_stack" VERSION 1.0)
+
+# Default options
+option(BUILD_KERNEL "Build the kernel driver" ON)
+option(BUILD_MAILBOX "Build the MHU mailbox kernel module" ON)
+
+# Add rpath to library directory
+set(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/lib")
+
+# Add include directory
+include_directories("kernel")
+
+# Add sub directories
+if(BUILD_KERNEL)
+ add_subdirectory(kernel)
+endif()
+
+if (BUILD_MAILBOX)
+ add_subdirectory(mailbox)
+endif()
+
+add_subdirectory(driver_library)
+add_subdirectory(utils)