aboutsummaryrefslogtreecommitdiff
path: root/lib/ethosu_profiler/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/ethosu_profiler/CMakeLists.txt')
-rw-r--r--lib/ethosu_profiler/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/lib/ethosu_profiler/CMakeLists.txt b/lib/ethosu_profiler/CMakeLists.txt
new file mode 100644
index 0000000..336a696
--- /dev/null
+++ b/lib/ethosu_profiler/CMakeLists.txt
@@ -0,0 +1,26 @@
+#
+# Copyright (c) 2021 Arm Limited. All rights reserved.
+#
+# SPDX-License-Identifier: Apache-2.0
+#
+# Licensed under the Apache License, Version 2.0 (the License); you may
+# not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an AS IS BASIS, WITHOUT
+# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+if (NOT TARGET ethosu_core_driver)
+ return()
+endif()
+add_library(ethosu_profiler INTERFACE)
+
+target_link_libraries(ethosu_profiler INTERFACE ethosu_core_driver tflu)
+target_include_directories(ethosu_profiler INTERFACE include)
+target_sources(ethosu_profiler INTERFACE src/ethosu_profiler.cpp)