aboutsummaryrefslogtreecommitdiff
path: root/lib/arm_profiler/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/arm_profiler/CMakeLists.txt')
-rw-r--r--lib/arm_profiler/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/lib/arm_profiler/CMakeLists.txt b/lib/arm_profiler/CMakeLists.txt
new file mode 100644
index 0000000..2452a50
--- /dev/null
+++ b/lib/arm_profiler/CMakeLists.txt
@@ -0,0 +1,23 @@
+#
+# Copyright (c) 2021 Arm Limited. All rights reserved.
+#
+# SPDX-License-Identifier: Apache-2.0
+#
+# Licensed under the Apache License, Version 2.0 (the License); you may
+# not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an AS IS BASIS, WITHOUT
+# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+add_library(arm_profiler INTERFACE)
+
+target_link_libraries(arm_profiler INTERFACE tflu)
+target_include_directories(arm_profiler INTERFACE include)
+target_sources(arm_profiler INTERFACE src/arm_profiler.cpp)