aboutsummaryrefslogtreecommitdiff
path: root/lib/layer_by_layer_profiler/CMakeLists.txt
diff options
context:
space:
mode:
authorJens Elofsson <jens.elofsson@arm.com>2021-05-23 17:37:07 +0200
committerMåns Nilsson <mans.nilsson@arm.com>2021-05-27 15:50:35 +0200
commit701a63b693bc877fc44abd802a9b2a431d81cfbe (patch)
tree5cfe3fb1c63b083b749c61af25c3b39e6a314907 /lib/layer_by_layer_profiler/CMakeLists.txt
parent036d1a89dffa4628f8d5b9a5b44ba9673ca2e3b4 (diff)
downloadethos-u-core-software-701a63b693bc877fc44abd802a9b2a431d81cfbe.tar.gz
Add Event Recorder Profiling
* Add event recorded profiling to ethosu_profiler. * Rename ethosu_profiler to layer_by_layer_profiler. Change-Id: Ie39c29845b2d1eb6d9d72e3fce68bf373e9dc888
Diffstat (limited to 'lib/layer_by_layer_profiler/CMakeLists.txt')
-rw-r--r--lib/layer_by_layer_profiler/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/lib/layer_by_layer_profiler/CMakeLists.txt b/lib/layer_by_layer_profiler/CMakeLists.txt
new file mode 100644
index 0000000..9774685
--- /dev/null
+++ b/lib/layer_by_layer_profiler/CMakeLists.txt
@@ -0,0 +1,26 @@
+#
+# Copyright (c) 2021 Arm Limited. All rights reserved.
+#
+# SPDX-License-Identifier: Apache-2.0
+#
+# Licensed under the Apache License, Version 2.0 (the License); you may
+# not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an AS IS BASIS, WITHOUT
+# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+if (NOT TARGET ethosu_core_driver)
+ return()
+endif()
+
+add_library(layer_by_layer_profiler INTERFACE)
+target_link_libraries(layer_by_layer_profiler INTERFACE ethosu_core_driver tflu event_recorder)
+target_include_directories(layer_by_layer_profiler INTERFACE include)
+target_sources(layer_by_layer_profiler INTERFACE src/layer_by_layer_profiler.cpp)