aboutsummaryrefslogtreecommitdiff
path: root/drivers/mailbox/CMakeLists.txt
diff options
context:
space:
mode:
authorJonny Svärd <jonny.svaerd@arm.com>2020-10-06 14:18:28 +0200
committerJonny Svärd <jonny.svaerd@arm.com>2020-10-09 14:23:21 +0200
commit44398c86f932b96911dd1558e2b66726943fcf46 (patch)
treec2ff3e24735c511f07dd902ebb7430602bec17d9 /drivers/mailbox/CMakeLists.txt
parentdc28b13e8bf4e5e7a788f289739e6301494c43a1 (diff)
downloadethos-u-core-software-44398c86f932b96911dd1558e2b66726943fcf46.tar.gz
Add a Mailbox interface
Change-Id: If68e70709c496849cb781af5f7288fa3f7ddcdb5
Diffstat (limited to 'drivers/mailbox/CMakeLists.txt')
-rw-r--r--drivers/mailbox/CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/drivers/mailbox/CMakeLists.txt b/drivers/mailbox/CMakeLists.txt
new file mode 100644
index 0000000..6d55407
--- /dev/null
+++ b/drivers/mailbox/CMakeLists.txt
@@ -0,0 +1,22 @@
+#
+# Copyright (c) 2020 Arm Limited. All rights reserved.
+#
+# SPDX-License-Identifier: Apache-2.0
+#
+# Licensed under the Apache License, Version 2.0 (the License); you may
+# not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an AS IS BASIS, WITHOUT
+# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+add_library(mailbox STATIC)
+target_include_directories(mailbox PUBLIC include)
+target_sources(mailbox PRIVATE src/mailbox.cc)
+