aboutsummaryrefslogtreecommitdiff
path: root/applications/inference_process/CMakeLists.txt
diff options
context:
space:
mode:
authorAnton Moberg <anton.moberg@arm.com>2021-07-07 11:08:17 +0200
committerFredrik Knutsson <fredrik.knutsson@arm.com>2021-07-15 09:46:02 +0000
commit07cf70b46cd2bf7db94a8d0e0d845eb44be24d1c (patch)
tree8c54c8d1785d58d2c336f695bd986350af3c0960 /applications/inference_process/CMakeLists.txt
parent67536759dce9d6a41d42c6403edc4482623eea0b (diff)
downloadethos-u-core-software-07cf70b46cd2bf7db94a8d0e0d845eb44be24d1c.tar.gz
Improved Logging - Core Software
Logging macros: Added ethosu_logging.h as a lib, containing logging macros controlled by a parameter ETHOSU_LOG_SEVERITY set in core_software CMakeLists.txt Updated inference_process: Updated inference_process to include ethosu_logging and use the logging macros rather than printf() Updated message_process: Updated message_process to include ethosu_logging and use the logging macros rather than printf() Updated ethosu_monitor: Updated ethosu_monitor to include ethosu_logging and use the logging macros rather than printf() Updated layer_by_layer_profiler: Updated layer_by_layer_profiler to include ethosu_logging and use the logging macros rather than printf() Updated mhu_v2: Updated mhu_v2 to include ethosu_logging and use the logging macros rather than printf() Change-Id: I5d6fd80b7645b3e0af5b494eea6dbb7755f02122
Diffstat (limited to 'applications/inference_process/CMakeLists.txt')
-rw-r--r--applications/inference_process/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/applications/inference_process/CMakeLists.txt b/applications/inference_process/CMakeLists.txt
index 1378181..19777fd 100644
--- a/applications/inference_process/CMakeLists.txt
+++ b/applications/inference_process/CMakeLists.txt
@@ -30,5 +30,8 @@ endif()
if (TARGET arm_profiler)
target_link_libraries(inference_process PRIVATE arm_profiler)
endif()
+if (TARGET ethosu_log)
+ target_link_libraries(inference_process PRIVATE ethosu_log)
+endif()
-target_sources(inference_process PRIVATE src/inference_process.cpp)
+target_sources(inference_process PRIVATE src/inference_process.cpp) \ No newline at end of file