aboutsummaryrefslogtreecommitdiff
path: root/targets/corstone-300/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'targets/corstone-300/CMakeLists.txt')
-rw-r--r--targets/corstone-300/CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/targets/corstone-300/CMakeLists.txt b/targets/corstone-300/CMakeLists.txt
index d41a7d3..7653926 100644
--- a/targets/corstone-300/CMakeLists.txt
+++ b/targets/corstone-300/CMakeLists.txt
@@ -52,6 +52,13 @@ set(TRUSTZONE_BUILD ON)
add_subdirectory(${CMAKE_CURRENT_SOURCE_DIR}/../common target)
+set(ETHOSU_TARGET_NPU_COUNT 1 CACHE INTERNAL "Number of NPUs")
+set(ETHOSU_TARGET_NPU_TA_COUNT 2 CACHE INTERNAL "Number of timing adapters per NPU")
+
+target_compile_definitions(ethosu_target_common INTERFACE
+ ETHOSU_NPU_TA_COUNT=${ETHOSU_TARGET_NPU_TA_COUNT}
+ ETHOSU_NPU_COUNT=${ETHOSU_TARGET_NPU_COUNT})
+
# Linker script
ethosu_target_link_options(ethosu_target_link INTERFACE
LINK_FILE platform
@@ -64,7 +71,7 @@ target_sources(ethosu_target_startup INTERFACE
target.cpp)
target_compile_definitions(ethosu_core_driver PUBLIC ETHOSU)
-target_link_libraries(ethosu_target_startup INTERFACE ethosu_core_driver)
+target_link_libraries(ethosu_target_startup INTERFACE ethosu_core_driver timing_adapter)
###############################################################################
# Applications