aboutsummaryrefslogtreecommitdiff
path: root/applications/trustzone_inference/secure/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'applications/trustzone_inference/secure/CMakeLists.txt')
-rw-r--r--applications/trustzone_inference/secure/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/applications/trustzone_inference/secure/CMakeLists.txt b/applications/trustzone_inference/secure/CMakeLists.txt
index 1e4a98b..b1f84f3 100644
--- a/applications/trustzone_inference/secure/CMakeLists.txt
+++ b/applications/trustzone_inference/secure/CMakeLists.txt
@@ -1,5 +1,5 @@
#
-# Copyright (c) 2021 Arm Limited. All rights reserved.
+# Copyright (c) 2021-2022 Arm Limited.
#
# SPDX-License-Identifier: Apache-2.0
#
@@ -38,8 +38,10 @@ target_compile_definitions(trustzone_secure PUBLIC TRUSTZONE_SECURE)
# Use the fast memory to support both 11.12.57 and 11.13.x release
# of the FVP
-target_compile_definitions(
- trustzone_secure PUBLIC ETHOSU_FAST_MEMORY_SIZE=0xa0000)
+target_compile_options(trustzone_secure PUBLIC
+ -UETHOSU_FAST_MEMORY_SIZE -DETHOSU_FAST_MEMORY_SIZE=0xa0000
+ -UETHOSU_ARENA -DETHOSU_ARENA=1
+ -UETHOSU_MODEL -DETHOSU_MODEL=1)
target_compile_options(trustzone_secure PUBLIC -mcmse)