aboutsummaryrefslogtreecommitdiff
path: root/applications/threadx_demo/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'applications/threadx_demo/CMakeLists.txt')
-rw-r--r--applications/threadx_demo/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/applications/threadx_demo/CMakeLists.txt b/applications/threadx_demo/CMakeLists.txt
index dbc56d2..c18d739 100644
--- a/applications/threadx_demo/CMakeLists.txt
+++ b/applications/threadx_demo/CMakeLists.txt
@@ -1,5 +1,5 @@
#
-# Copyright (c) 2021 Arm Limited. All rights reserved.
+# Copyright (c) 2021-2022 Arm Limited.
#
# SPDX-License-Identifier: Apache-2.0
#
@@ -31,5 +31,7 @@ target_include_directories(threadx_demo PRIVATE models/mobilenet_v2)
# Use the fast memory to support both 11.12.57 and 11.13.x release
# of the FVP
# The size is defined to force the .bss.tensor_arena to be placed in DDR
-target_compile_definitions(
- threadx_demo PRIVATE ETHOSU_FAST_MEMORY_SIZE=0xa0000)
+target_compile_options(threadx_demo PRIVATE
+ -UETHOSU_FAST_MEMORY_SIZE -DETHOSU_FAST_MEMORY_SIZE=0xa0000
+ -UETHOSU_ARENA -DETHOSU_ARENA=1
+ -UETHOSU_MODEL -DETHOSU_MODEL=1)