aboutsummaryrefslogtreecommitdiff
path: root/applications/freertos/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'applications/freertos/CMakeLists.txt')
-rw-r--r--applications/freertos/CMakeLists.txt9
1 files changed, 5 insertions, 4 deletions
diff --git a/applications/freertos/CMakeLists.txt b/applications/freertos/CMakeLists.txt
index 610f0e5..7bbfd97 100644
--- a/applications/freertos/CMakeLists.txt
+++ b/applications/freertos/CMakeLists.txt
@@ -1,5 +1,5 @@
#
-# Copyright (c) 2021 Arm Limited. All rights reserved.
+# Copyright (c) 2021-2022 Arm Limited.
#
# SPDX-License-Identifier: Apache-2.0
#
@@ -29,6 +29,7 @@ target_include_directories(freertos PRIVATE models/mobilenet_v2)
# Use the fast memory to support both 11.12.57 and 11.13.x release
# of the FVP
-# The size is defined to force the .bss.tensor_arena to be placed in DDR
-target_compile_definitions(
- freertos PRIVATE ETHOSU_FAST_MEMORY_SIZE=0xa0000)
+target_compile_options(freertos PRIVATE
+ -UETHOSU_FAST_MEMORY_SIZE -DETHOSU_FAST_MEMORY_SIZE=0xa0000
+ -UETHOSU_ARENA -DETHOSU_ARENA=1
+ -UETHOSU_MODEL -DETHOSU_MODEL=1)