aboutsummaryrefslogtreecommitdiff
path: root/applications/freertos/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'applications/freertos/CMakeLists.txt')
-rw-r--r--applications/freertos/CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/applications/freertos/CMakeLists.txt b/applications/freertos/CMakeLists.txt
new file mode 100644
index 0000000..f803d43
--- /dev/null
+++ b/applications/freertos/CMakeLists.txt
@@ -0,0 +1,27 @@
+#
+# Copyright (c) 2021 Arm Limited. All rights reserved.
+#
+# SPDX-License-Identifier: Apache-2.0
+#
+# Licensed under the Apache License, Version 2.0 (the License); you may
+# not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an AS IS BASIS, WITHOUT
+# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+# Exclude this app if freertos target does not exist
+if (NOT TARGET freertos_kernel)
+ message("Skipping FreeRTOS application")
+ return()
+endif()
+
+ethosu_add_executable(freertos PRIVATE
+ SOURCES main.cpp
+ LIBRARIES freertos_kernel)