aboutsummaryrefslogtreecommitdiff
path: root/applications/driver_unit_tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'applications/driver_unit_tests/CMakeLists.txt')
-rw-r--r--applications/driver_unit_tests/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/applications/driver_unit_tests/CMakeLists.txt b/applications/driver_unit_tests/CMakeLists.txt
new file mode 100644
index 0000000..b679358
--- /dev/null
+++ b/applications/driver_unit_tests/CMakeLists.txt
@@ -0,0 +1,30 @@
+#
+# Copyright (c) 2021 Arm Limited. All rights reserved.
+#
+# SPDX-License-Identifier: Apache-2.0
+#
+# Licensed under the Apache License, Version 2.0 (the License); you may
+# not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an AS IS BASIS, WITHOUT
+# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+add_library(driver_unit INTERFACE)
+
+target_sources(driver_unit INTERFACE
+ command_stream.cpp)
+
+ethosu_add_executable_test(driver_unit_irq PRIVATE
+ SOURCES irq.cpp
+ LIBRARIES driver_unit)
+
+ethosu_add_executable_test(driver_unit_conv PRIVATE
+ SOURCES conv.cpp
+ LIBRARIES driver_unit)