aboutsummaryrefslogtreecommitdiff
path: root/applications/baremetal/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'applications/baremetal/CMakeLists.txt')
-rw-r--r--applications/baremetal/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/applications/baremetal/CMakeLists.txt b/applications/baremetal/CMakeLists.txt
index c0ecf03..37073bb 100644
--- a/applications/baremetal/CMakeLists.txt
+++ b/applications/baremetal/CMakeLists.txt
@@ -21,16 +21,18 @@ set(BAREMETAL_PATH "" CACHE PATH "Path to input, output and network for baremeta
if (IS_DIRECTORY ${BAREMETAL_PATH})
ethosu_add_executable_test(baremetal_custom PRIVATE
SOURCES main.cpp
- LIBRARIES ethosu_monitor)
+ LIBRARIES $<$<TARGET_EXISTS:ethosu_monitor>:ethosu_monitor>)
target_include_directories(baremetal_custom PRIVATE ${BAREMETAL_PATH})
endif()
-file(GLOB models LIST_DIRECTORIES true "${CMAKE_CURRENT_SOURCE_DIR}/models/${ETHOSU_TARGET_NPU_CONFIG}/*")
+if (TARGET ethosu_core_driver)
+ file(GLOB models LIST_DIRECTORIES true "${CMAKE_CURRENT_SOURCE_DIR}/models/${ETHOSU_TARGET_NPU_CONFIG}/*")
+endif()
foreach(model ${models})
get_filename_component(name ${model} NAME)
ethosu_add_executable_test(baremetal_${name} PRIVATE
SOURCES main.cpp
- LIBRARIES ethosu_monitor)
+ LIBRARIES $<$<TARGET_EXISTS:ethosu_monitor>:ethosu_monitor>)
target_include_directories(baremetal_${name} PRIVATE ${model})
endforeach() \ No newline at end of file