aboutsummaryrefslogtreecommitdiff
path: root/targets/corstone-300/CMakeLists.txt
diff options
context:
space:
mode:
authorJonny Svärd <jonny.svaerd@arm.com>2021-03-18 15:49:27 +0100
committerJonny Svärd <jonny.svaerd@arm.com>2021-03-24 10:14:54 +0100
commitd66709083f08b4c32792d4a93e1e5b3c6b913fb2 (patch)
tree05e278bd3d8102baddbd87ebe6b2ef2404533ac2 /targets/corstone-300/CMakeLists.txt
parentad2d25e46c7fa521790e1f0f1b72fc9969139751 (diff)
downloadethos-u-core-platform-d66709083f08b4c32792d4a93e1e5b3c6b913fb2.tar.gz
Use new timing adapter driver from core_software
Add basic skeleton to initialize timing adapters. See core_software/drivers/timing_adapter/include/timing_adapter.h for description of settings and API. Change-Id: I0884f8efc5735b1a837d45e0bb7c6612d329ad58
Diffstat (limited to 'targets/corstone-300/CMakeLists.txt')
-rw-r--r--targets/corstone-300/CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/targets/corstone-300/CMakeLists.txt b/targets/corstone-300/CMakeLists.txt
index d41a7d3..7653926 100644
--- a/targets/corstone-300/CMakeLists.txt
+++ b/targets/corstone-300/CMakeLists.txt
@@ -52,6 +52,13 @@ set(TRUSTZONE_BUILD ON)
add_subdirectory(${CMAKE_CURRENT_SOURCE_DIR}/../common target)
+set(ETHOSU_TARGET_NPU_COUNT 1 CACHE INTERNAL "Number of NPUs")
+set(ETHOSU_TARGET_NPU_TA_COUNT 2 CACHE INTERNAL "Number of timing adapters per NPU")
+
+target_compile_definitions(ethosu_target_common INTERFACE
+ ETHOSU_NPU_TA_COUNT=${ETHOSU_TARGET_NPU_TA_COUNT}
+ ETHOSU_NPU_COUNT=${ETHOSU_TARGET_NPU_COUNT})
+
# Linker script
ethosu_target_link_options(ethosu_target_link INTERFACE
LINK_FILE platform
@@ -64,7 +71,7 @@ target_sources(ethosu_target_startup INTERFACE
target.cpp)
target_compile_definitions(ethosu_core_driver PUBLIC ETHOSU)
-target_link_libraries(ethosu_target_startup INTERFACE ethosu_core_driver)
+target_link_libraries(ethosu_target_startup INTERFACE ethosu_core_driver timing_adapter)
###############################################################################
# Applications