aboutsummaryrefslogtreecommitdiff
path: root/drivers/mhu_v2/CMakeLists.txt
diff options
context:
space:
mode:
authorYulia Garbovich <yulia.garbovich@arm.com>2021-11-23 20:00:04 +0200
committerYulia Garbovich <yulia.garbovich@arm.com>2021-12-14 11:43:57 +0200
commite9cdc6374dc730dc61d2a8a81beabe563ad7fe88 (patch)
treee56813c3fb447cf0bb9200157f802971d6f40be8 /drivers/mhu_v2/CMakeLists.txt
parent29467e04fbc15f53001c0c95227db34160b776e7 (diff)
downloadethos-u-core-platform-e9cdc6374dc730dc61d2a8a81beabe563ad7fe88.tar.gz
Add mpu driver and remove interface library
from drivers Add mpu driver for upstreaming After removing of interface library,targets and applications will list explicitly which libraries to link Change-Id: Icfa449a2981093161f283e45b4d52ca6199371b8
Diffstat (limited to 'drivers/mhu_v2/CMakeLists.txt')
-rw-r--r--drivers/mhu_v2/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/drivers/mhu_v2/CMakeLists.txt b/drivers/mhu_v2/CMakeLists.txt
new file mode 100644
index 0000000..2505901
--- /dev/null
+++ b/drivers/mhu_v2/CMakeLists.txt
@@ -0,0 +1,23 @@
+#
+# Copyright (c) 2020-2021 Arm Limited. All rights reserved.
+#
+# SPDX-License-Identifier: Apache-2.0
+#
+# Licensed under the Apache License, Version 2.0 (the License); you may
+# not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an AS IS BASIS, WITHOUT
+# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+add_library(ethosu_mhu_v2 STATIC)
+target_include_directories(ethosu_mhu_v2 PUBLIC include)
+
+target_sources(ethosu_mhu_v2 PRIVATE src/mhu_v2.cpp)
+target_link_libraries(ethosu_mhu_v2 PRIVATE ethosu_mailbox ethosu_log)