aboutsummaryrefslogtreecommitdiff
path: root/applications/message_handler/test/test_message_handler/CMakeLists.txt
diff options
context:
space:
mode:
authorKristofer Jonsson <kristofer.jonsson@arm.com>2023-02-08 14:23:00 +0100
committerKristofer Jonsson <kristofer.jonsson@arm.com>2023-02-08 14:44:01 +0100
commit3f5510fa3444217a442ac2e63ae50b27c9c26cf3 (patch)
treedbf2f8bb631af6e3a67d512835e17395e8e07704 /applications/message_handler/test/test_message_handler/CMakeLists.txt
parent87f6f7ebf5a51be7c819503894f486d05f2a8b31 (diff)
downloadethos-u-core-platform-3f5510fa3444217a442ac2e63ae50b27c9c26cf3.tar.gz
Updating message handler firmware23.02-rc1
The 'message handler' firmware was based on a custom interface between Linux and the firmware. Because the kernel driver has been converted into a rpmsg driver, the 'message handler' application has been updated into an OpenAMP based firmware. Change-Id: I1339180c4f53cbad42501a2827863b7b49561ff4
Diffstat (limited to 'applications/message_handler/test/test_message_handler/CMakeLists.txt')
-rw-r--r--applications/message_handler/test/test_message_handler/CMakeLists.txt38
1 files changed, 0 insertions, 38 deletions
diff --git a/applications/message_handler/test/test_message_handler/CMakeLists.txt b/applications/message_handler/test/test_message_handler/CMakeLists.txt
deleted file mode 100644
index bdccf54..0000000
--- a/applications/message_handler/test/test_message_handler/CMakeLists.txt
+++ /dev/null
@@ -1,38 +0,0 @@
-#
-# Copyright (c) 2020-2022 Arm Limited.
-#
-# SPDX-License-Identifier: Apache-2.0
-#
-# Licensed under the Apache License, Version 2.0 (the License); you may
-# not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an AS IS BASIS, WITHOUT
-# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-#
-
-if(NOT BUILD_TEST_MESSAGE_HANDLER OR NOT TARGET freertos_kernel)
- message("Skipping test message handler")
- return()
-endif()
-
-ethosu_add_executable(test_message_handler
- SOURCES
- main.cpp
- LIBRARIES
- message_handler_lib
- freertos_kernel)
-
-target_include_directories(test_message_handler PRIVATE
- ../../indexed_networks
- ${LINUX_DRIVER_STACK_PATH}/kernel)
-
-install(FILES $<TARGET_FILE:test_message_handler>
- DESTINATION "lib/firmware"
- RENAME "arm-test-${ETHOSU_TARGET_NPU_CONFIG}.fw"
-)