aboutsummaryrefslogtreecommitdiff
path: root/applications/freertos/CMakeLists.txt
diff options
context:
space:
mode:
authorPer Åstrand <per.astrand@arm.com>2021-02-19 13:45:26 +0100
committerPer Åstrand <per.astrand@arm.com>2021-02-24 15:58:56 +0100
commit81e01af108cd006e0e12aacd2b2a0bb1a0ce8684 (patch)
tree0ec4a5dde2de792fba76bb03d7df4fb90014b6bd /applications/freertos/CMakeLists.txt
parentea650ac6a492edcdf487f17875ad6446a51397a5 (diff)
downloadethos-u-core-platform-81e01af108cd006e0e12aacd2b2a0bb1a0ce8684.tar.gz
Use mobilenet_v2 for freertos test application
Replace the CPU-only network with mobilenet_v2_1.0_224. The header files in this commit are the same as the model data in the trustzone application, see the README.md in applications/trustzone_inference for details on how to generate them from source on Arm ML-Zoo repository on github. Change-Id: I8d3cfd6313fd5d98880cf1b24511208ca12faa05
Diffstat (limited to 'applications/freertos/CMakeLists.txt')
-rw-r--r--applications/freertos/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/applications/freertos/CMakeLists.txt b/applications/freertos/CMakeLists.txt
index 0bd1de6..9581fe5 100644
--- a/applications/freertos/CMakeLists.txt
+++ b/applications/freertos/CMakeLists.txt
@@ -25,3 +25,9 @@ endif()
ethosu_add_executable_test(freertos PRIVATE
SOURCES main.cpp
LIBRARIES freertos_kernel)
+
+# Use the fast memory to support both 11.12.57 and 11.13.x release
+# of the FVP
+# The size is defined to force the .bss.NoInit to be placed in DDR
+target_compile_definitions(
+ freertos PRIVATE ETHOSU_FAST_MEMORY_SIZE=0xa0000)