aboutsummaryrefslogtreecommitdiff
path: root/applications/baremetal/CMakeLists.txt
diff options
context:
space:
mode:
authorKristofer Jonsson <kristofer.jonsson@arm.com>2021-11-24 14:16:34 +0100
committerKristofer Jonsson <kristofer.jonsson@arm.com>2021-11-25 15:31:56 +0100
commit15625f17e4c5f71be970cda8bf918cc00e613cad (patch)
treed37a09a9c6ecd879a9b39fb8f3126134b23e9d79 /applications/baremetal/CMakeLists.txt
parente07dda6a06e66b055e9302d8c35233ff87e3e934 (diff)
downloadethos-u-core-platform-15625f17e4c5f71be970cda8bf918cc00e613cad.tar.gz
Exclude applications that depend on NPU
Exclude applications that depend on the NPU, if the NPU driver library was not compiled by the project. Change-Id: I3fcb570cf155d589a9576266332ba519a11186f1
Diffstat (limited to 'applications/baremetal/CMakeLists.txt')
-rw-r--r--applications/baremetal/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/applications/baremetal/CMakeLists.txt b/applications/baremetal/CMakeLists.txt
index c0ecf03..37073bb 100644
--- a/applications/baremetal/CMakeLists.txt
+++ b/applications/baremetal/CMakeLists.txt
@@ -21,16 +21,18 @@ set(BAREMETAL_PATH "" CACHE PATH "Path to input, output and network for baremeta
if (IS_DIRECTORY ${BAREMETAL_PATH})
ethosu_add_executable_test(baremetal_custom PRIVATE
SOURCES main.cpp
- LIBRARIES ethosu_monitor)
+ LIBRARIES $<$<TARGET_EXISTS:ethosu_monitor>:ethosu_monitor>)
target_include_directories(baremetal_custom PRIVATE ${BAREMETAL_PATH})
endif()
-file(GLOB models LIST_DIRECTORIES true "${CMAKE_CURRENT_SOURCE_DIR}/models/${ETHOSU_TARGET_NPU_CONFIG}/*")
+if (TARGET ethosu_core_driver)
+ file(GLOB models LIST_DIRECTORIES true "${CMAKE_CURRENT_SOURCE_DIR}/models/${ETHOSU_TARGET_NPU_CONFIG}/*")
+endif()
foreach(model ${models})
get_filename_component(name ${model} NAME)
ethosu_add_executable_test(baremetal_${name} PRIVATE
SOURCES main.cpp
- LIBRARIES ethosu_monitor)
+ LIBRARIES $<$<TARGET_EXISTS:ethosu_monitor>:ethosu_monitor>)
target_include_directories(baremetal_${name} PRIVATE ${model})
endforeach() \ No newline at end of file