aboutsummaryrefslogtreecommitdiff
path: root/applications/baremetal/CMakeLists.txt
diff options
context:
space:
mode:
authorAnton Moberg <anton.moberg@arm.com>2021-03-17 15:45:27 +0100
committerAnton Moberg <anton.moberg@arm.com>2021-03-18 10:00:42 +0100
commitd121356df282ddf8992c228995725f3f0210f701 (patch)
tree19cbd74359607119737a2f5e79ab5a5708af9f6a /applications/baremetal/CMakeLists.txt
parent456566daf2be5b34fd0659854d2807e8bc3b461b (diff)
downloadethos-u-core-platform-d121356df282ddf8992c228995725f3f0210f701.tar.gz
Smaller networks - keyword_spotting_dnn_medium_int8
Added: Baremetal application 'keyword_spotting_dnn_medium_int8' as and executable test. Run with ctest -R keyword_spotting_dnn_medium_int8 Model taken from ML-zoo, run through vela, and hexdumped to C header format. Change-Id: Iba97a2c89277131605e233f0c9241581ea178755
Diffstat (limited to 'applications/baremetal/CMakeLists.txt')
-rw-r--r--applications/baremetal/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/applications/baremetal/CMakeLists.txt b/applications/baremetal/CMakeLists.txt
index 836ec28..299b3f1 100644
--- a/applications/baremetal/CMakeLists.txt
+++ b/applications/baremetal/CMakeLists.txt
@@ -18,4 +18,8 @@
ethosu_add_executable_test(baremetal_keyword_cnn PRIVATE
SOURCES main.cpp)
-target_include_directories(baremetal_keyword_cnn PRIVATE models/keyword_spotting_cnn_small_int8) \ No newline at end of file
+target_include_directories(baremetal_keyword_cnn PRIVATE models/keyword_spotting_cnn_small_int8)
+
+ethosu_add_executable_test(baremetal_keyword_dnn PRIVATE
+ SOURCES main.cpp)
+target_include_directories(baremetal_keyword_dnn PRIVATE models/keyword_spotting_dnn_medium_int8) \ No newline at end of file