aboutsummaryrefslogtreecommitdiff
path: root/applications/baremetal/CMakeLists.txt
diff options
context:
space:
mode:
authorAnton Moberg <anton.moberg@arm.com>2021-03-17 16:06:21 +0100
committerAnton Moberg <anton.moberg@arm.com>2021-03-18 10:01:19 +0100
commitad2d25e46c7fa521790e1f0f1b72fc9969139751 (patch)
tree4374e3b33388f16a459234b90672429ffa791dc6 /applications/baremetal/CMakeLists.txt
parentd121356df282ddf8992c228995725f3f0210f701 (diff)
downloadethos-u-core-platform-ad2d25e46c7fa521790e1f0f1b72fc9969139751.tar.gz
Smaller networks - keyword_spotting_ds_dnn_large_clustered_int8
Added: Baremetal application 'keyword_spotting_ds_dnn_large_clustered_int8' as and executable test. Run with ctest -R keyword_spotting_ds_dnn_large_clustered_int8 Model taken from ML-zoo, run through vela, and hexdumped to C header format. Change-Id: If1cee9f45bf9886eace299a378523b81beee4798
Diffstat (limited to 'applications/baremetal/CMakeLists.txt')
-rw-r--r--applications/baremetal/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/applications/baremetal/CMakeLists.txt b/applications/baremetal/CMakeLists.txt
index 299b3f1..129fd3f 100644
--- a/applications/baremetal/CMakeLists.txt
+++ b/applications/baremetal/CMakeLists.txt
@@ -22,4 +22,8 @@ target_include_directories(baremetal_keyword_cnn PRIVATE models/keyword_spotting
ethosu_add_executable_test(baremetal_keyword_dnn PRIVATE
SOURCES main.cpp)
-target_include_directories(baremetal_keyword_dnn PRIVATE models/keyword_spotting_dnn_medium_int8) \ No newline at end of file
+target_include_directories(baremetal_keyword_dnn PRIVATE models/keyword_spotting_dnn_medium_int8)
+
+ethosu_add_executable_test(baremetal_keyword_ds_dnn PRIVATE
+ SOURCES main.cpp)
+target_include_directories(baremetal_keyword_ds_dnn PRIVATE models/keyword_spotting_ds_dnn_large_clustered_int8) \ No newline at end of file