aboutsummaryrefslogtreecommitdiff
path: root/applications/baremetal/CMakeLists.txt
diff options
context:
space:
mode:
authorAnton Moberg <anton.moberg@arm.com>2021-03-17 10:19:26 +0100
committerAnton Moberg <anton.moberg@arm.com>2021-03-18 10:00:04 +0100
commit456566daf2be5b34fd0659854d2807e8bc3b461b (patch)
tree17bbe8e2cf6ca6867236159fe9a7b23ffe876c1f /applications/baremetal/CMakeLists.txt
parentbd59c79d70d9cb2e8bd5fd4b13204cf6df6fcd62 (diff)
downloadethos-u-core-platform-456566daf2be5b34fd0659854d2807e8bc3b461b.tar.gz
Smaller networks - keyword_spotting_cnn_small_int8
Added: Baremetal folder for baremetal applications Added: Baremetal application 'keyword_spotting_cnn_small_int8' as an executable test. Run with ctest -R keyword_spotting_cnn_small_int8 Model taken from ML-zoo, run through vela, and hexdumped to C header format. Change-Id: I053d88a4319cb58020027d6007e83fd519a2af6e
Diffstat (limited to 'applications/baremetal/CMakeLists.txt')
-rw-r--r--applications/baremetal/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/applications/baremetal/CMakeLists.txt b/applications/baremetal/CMakeLists.txt
new file mode 100644
index 0000000..836ec28
--- /dev/null
+++ b/applications/baremetal/CMakeLists.txt
@@ -0,0 +1,21 @@
+#
+# Copyright (c) 2021 Arm Limited. All rights reserved.
+#
+# SPDX-License-Identifier: Apache-2.0
+#
+# Licensed under the Apache License, Version 2.0 (the License); you may
+# not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an AS IS BASIS, WITHOUT
+# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+ethosu_add_executable_test(baremetal_keyword_cnn PRIVATE
+ SOURCES main.cpp)
+target_include_directories(baremetal_keyword_cnn PRIVATE models/keyword_spotting_cnn_small_int8) \ No newline at end of file