aboutsummaryrefslogtreecommitdiff
path: root/third-party/fmt/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'third-party/fmt/CMakeLists.txt')
-rw-r--r--third-party/fmt/CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/third-party/fmt/CMakeLists.txt b/third-party/fmt/CMakeLists.txt
new file mode 100644
index 0000000000..496ae1fbc6
--- /dev/null
+++ b/third-party/fmt/CMakeLists.txt
@@ -0,0 +1,19 @@
+#
+# Copyright © 2020 Arm Ltd. All rights reserved.
+# SPDX-License-Identifier: MIT
+#
+
+add_library(fmt INTERFACE)
+
+target_compile_definitions(fmt INTERFACE FMT_HEADER_ONLY=1)
+
+target_include_directories(fmt SYSTEM INTERFACE
+ $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}>
+ $<INSTALL_INTERFACE:${CMAKE_INSTALL_INCLUDEDIR}>)
+
+install(
+ TARGETS fmt
+ EXPORT armnn-targets
+ LIBRARY DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}
+ ARCHIVE DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}
+) \ No newline at end of file