aboutsummaryrefslogtreecommitdiff
path: root/src/timelineDecoder/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/timelineDecoder/CMakeLists.txt')
-rw-r--r--src/timelineDecoder/CMakeLists.txt16
1 files changed, 7 insertions, 9 deletions
diff --git a/src/timelineDecoder/CMakeLists.txt b/src/timelineDecoder/CMakeLists.txt
index e7d5481eb5..af5addadfe 100644
--- a/src/timelineDecoder/CMakeLists.txt
+++ b/src/timelineDecoder/CMakeLists.txt
@@ -4,8 +4,8 @@
#
if(BUILD_TIMELINE_DECODER)
- set(jsonTimelineDecoder_sources)
- list(APPEND jsonTimelineDecoder_sources
+ set(timelineDecoderJson_sources)
+ list(APPEND timelineDecoderJson_sources
JSONTimelineDecoder.cpp
JSONTimelineDecoder.hpp)
@@ -18,16 +18,14 @@ if(BUILD_TIMELINE_DECODER)
target_include_directories(UnitTests PRIVATE ${PROJECT_SOURCE_DIR}/src/timelineDecoder)
endif()
- add_library_ex(jsonTimelineDecoder SHARED ${jsonTimelineDecoder_sources})
+ add_library_ex(timelineDecoderJson SHARED ${timelineDecoderJson_sources})
- set_target_properties(jsonTimelineDecoder PROPERTIES LIBRARY_OUTPUT_DIRECTORY ${PROJECT_BINARY_DIR})
- set_target_properties(jsonTimelineDecoder PROPERTIES VERSION ${GENERIC_LIB_VERSION} SOVERSION ${GENERIC_LIB_SOVERSION} )
+ set_target_properties(timelineDecoderJson PROPERTIES LIBRARY_OUTPUT_DIRECTORY ${PROJECT_BINARY_DIR})
+ set_target_properties(timelineDecoderJson PROPERTIES VERSION ${GENERIC_LIB_VERSION} SOVERSION ${GENERIC_LIB_SOVERSION} )
- target_link_libraries(jsonTimelineDecoder armnn)
+ target_link_libraries(timelineDecoderJson armnn)
- install(TARGETS jsonTimelineDecoder
+ install(TARGETS timelineDecoderJson
LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
endif()
-
-