aboutsummaryrefslogtreecommitdiff
path: root/src/armnnSerializer/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/armnnSerializer/CMakeLists.txt')
-rwxr-xr-xsrc/armnnSerializer/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/armnnSerializer/CMakeLists.txt b/src/armnnSerializer/CMakeLists.txt
index 919a68bd0e..b7e65ad090 100755
--- a/src/armnnSerializer/CMakeLists.txt
+++ b/src/armnnSerializer/CMakeLists.txt
@@ -3,11 +3,17 @@
# SPDX-License-Identifier: MIT
#
if(BUILD_ARMNN_SERIALIZER)
+ # We're using NO_SYSTEM_ENVIRONMENT_PATH to prevent a system installed
+ # flatc being found and used.
find_program(FLATC flatc
HINTS ${FLATC_DIR}
+ NO_SYSTEM_ENVIRONMENT_PATH
DOC "Path to 'flatc', the flatbuffers compiler")
+
if (NOT FLATC)
message(SEND_ERROR "flatc not found. Specify the full path of the flatc executable with -DFLATC=<flatc path>")
+ else()
+ message("Using flatc was from: ${FLATC}")
endif()
add_custom_command(