aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 867fb34071..5b80430d7d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -822,6 +822,7 @@ if(BUILD_UNIT_TESTS)
if(BUILD_GATORD_MOCK)
list(APPEND unittest_sources
tests/profiling/gatordmock/tests/GatordMockTests.cpp
+ tests/profiling/timelineDecoder/tests/TimelineTests.cpp
)
endif()
@@ -936,6 +937,13 @@ if(BUILD_GATORD_MOCK)
tests/profiling/gatordmock/PeriodicCounterCaptureCommandHandler.hpp
tests/profiling/gatordmock/PeriodicCounterSelectionResponseHandler.cpp
tests/profiling/gatordmock/PeriodicCounterSelectionResponseHandler.hpp
+ tests/profiling/timelineDecoder/ITimelineDecoder.h
+ tests/profiling/timelineDecoder/TimelineCaptureCommandHandler.cpp
+ tests/profiling/timelineDecoder/TimelineCaptureCommandHandler.hpp
+ tests/profiling/timelineDecoder/TimelineDecoder.cpp
+ tests/profiling/timelineDecoder/TimelineDirectoryCaptureCommandHandler.cpp
+ tests/profiling/timelineDecoder/TimelineDirectoryCaptureCommandHandler.hpp
+ tests/profiling/timelineDecoder/tests/TimelineTestFunctions.hpp
)
include_directories(${Boost_INCLUDE_DIRS} src/profiling)