aboutsummaryrefslogtreecommitdiff
path: root/tests/MemoryStrategyBenchmark/CMakeLists.txt
diff options
context:
space:
mode:
authorJim Flynn <jim.flynn@arm.com>2021-10-26 21:26:10 +0100
committerJim Flynn <jim.flynn@arm.com>2021-10-26 21:27:22 +0100
commite1fdd2866b0f403b5e80994890d62c2c038c16c9 (patch)
treed7398443532cbafde7c6824015397e6bac6dd502 /tests/MemoryStrategyBenchmark/CMakeLists.txt
parentca5883951ab51191eb19502459f0936fc96e14f1 (diff)
downloadarmnn-e1fdd2866b0f403b5e80994890d62c2c038c16c9.tar.gz
IVGCVSW-6470 Create MemoryStrategyBenchmark
* Refactor the strategy library to be more generic * Shorten the names of the current strategies * Change validatorStrat to throw exceptions Change-Id: I0d9c9ef609b2d8675e5788610d1accac6767c660 Signed-off-by: Finn Williams <finwil01@e127804.cambridge.arm.com> Signed-off-by: Jim Flynn <jim.flynn@arm.com>
Diffstat (limited to 'tests/MemoryStrategyBenchmark/CMakeLists.txt')
-rw-r--r--tests/MemoryStrategyBenchmark/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/tests/MemoryStrategyBenchmark/CMakeLists.txt b/tests/MemoryStrategyBenchmark/CMakeLists.txt
new file mode 100644
index 0000000000..9ed79bae5f
--- /dev/null
+++ b/tests/MemoryStrategyBenchmark/CMakeLists.txt
@@ -0,0 +1,16 @@
+add_executable(MemoryStrategyBenchmark
+ MemoryStrategyBenchmark.cpp
+ TestBlocks.hpp
+ TestStrategy.hpp
+ TestStrategy.cpp
+ ../../include/armnn/Exceptions.hpp
+ ../../src/armnn/Exceptions.cpp)
+
+target_link_libraries(MemoryStrategyBenchmark armnnMemoryOptimizationStrategies)
+target_include_directories(MemoryStrategyBenchmark PRIVATE
+ ../../include/armnn/backends
+ ../../src/backends/backendsCommon/memoryOptimizerStrategyLibrary
+ ../../third-party/cxxopts)
+
+
+set_target_properties(MemoryStrategyBenchmark PROPERTIES LINKER_LANGUAGE CXX) \ No newline at end of file