aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorJim Flynn <jim.flynn@arm.com>2021-10-26 21:26:10 +0100
committerJim Flynn <jim.flynn@arm.com>2021-10-26 21:27:22 +0100
commite1fdd2866b0f403b5e80994890d62c2c038c16c9 (patch)
treed7398443532cbafde7c6824015397e6bac6dd502 /tests/CMakeLists.txt
parentca5883951ab51191eb19502459f0936fc96e14f1 (diff)
downloadarmnn-e1fdd2866b0f403b5e80994890d62c2c038c16c9.tar.gz
IVGCVSW-6470 Create MemoryStrategyBenchmark
* Refactor the strategy library to be more generic * Shorten the names of the current strategies * Change validatorStrat to throw exceptions Change-Id: I0d9c9ef609b2d8675e5788610d1accac6767c660 Signed-off-by: Finn Williams <finwil01@e127804.cambridge.arm.com> Signed-off-by: Jim Flynn <jim.flynn@arm.com>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 1531fd5f24..cea55c5b8e 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -221,3 +221,7 @@ if(BUILD_ACCURACY_TOOL)
target_include_directories(ImageCSVFileGenerator PRIVATE ../src/armnnUtils)
ImageTensorExecutor(ImageCSVFileGenerator)
endif()
+
+if(BUILD_MEMORY_STRATEGY_BENCHMARK)
+ add_subdirectory(MemoryStrategyBenchmark)
+endif()