aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorTeresa Charlin <teresa.charlinreyes@arm.com>2022-07-07 14:24:59 +0100
committerNikhil Raj <nikhil.raj@arm.com>2022-07-28 15:08:22 +0100
commit83b429107a4bb1fe84e756c29d8ad3771d4beeee (patch)
treec383d2692365a8166b949f90267e152f0624704f /tests/CMakeLists.txt
parent46f298657c14c1b0a4b0690ecce49f64dc0a7010 (diff)
downloadarmnn-83b429107a4bb1fe84e756c29d8ad3771d4beeee.tar.gz
Revert "Revert "IVGCVSW-6650 Refactor ExecuteNetwork""
This reverts commit 1a7f033768acb27da11503bd29abb468d2e77f9e. List of fixes to be able to add this code again: * "emplacing_back" the vector inputTensors into the vector m_InputTensorsVec outside the for loop * GetIOInfo() uses IOptimizedNetwork instead of INetwork, where the infered shapes are not saved * Add missing data type Signed32 to SetupInputsAndOutputs() * PrintOutputTensors() prints the actual output without dequantizing * Add profilingDetailsMethod as input in networkProperties in ArmNNExecutor constructor * Fix typos Change-Id: I91de166f87228282db3efa27431fe91458834442 Signed-off-by: Teresa Charlin <teresa.charlinreyes@arm.com> Change-Id: Ic6634d48892d11e5f146cdf285e1e333e93e9937 Signed-off-by: Francis Murtagh <francis.murtagh@arm.com>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 9f377c6466..9ac9bcb636 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -144,6 +144,9 @@ if (BUILD_ARMNN_SERIALIZER
OR BUILD_ONNX_PARSER
OR BUILD_ARMNN_TFLITE_DELEGATE)
set(ExecuteNetwork_sources
+ ExecuteNetwork/IExecutor.hpp
+ ExecuteNetwork/ArmNNExecutor.cpp
+ ExecuteNetwork/ArmNNExecutor.hpp
ExecuteNetwork/ExecuteNetwork.cpp
ExecuteNetwork/ExecuteNetworkProgramOptions.cpp
ExecuteNetwork/ExecuteNetworkProgramOptions.hpp
@@ -152,6 +155,13 @@ if (BUILD_ARMNN_SERIALIZER
NetworkExecutionUtils/NetworkExecutionUtils.cpp
NetworkExecutionUtils/NetworkExecutionUtils.hpp)
+ if(BUILD_ARMNN_TFLITE_DELEGATE)
+ set(ExecuteNetwork_sources
+ ${ExecuteNetwork_sources}
+ ExecuteNetwork/TfliteExecutor.cpp
+ ExecuteNetwork/TfliteExecutor.hpp)
+ endif()
+
add_executable_ex(ExecuteNetwork ${ExecuteNetwork_sources})
target_include_directories(ExecuteNetwork PRIVATE ../src/armnn)
target_include_directories(ExecuteNetwork PRIVATE ../src/armnnUtils)