aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorJan Eilers <jan.eilers@arm.com>2021-12-08 16:15:12 +0000
committerJan Eilers <jan.eilers@arm.com>2021-12-08 16:15:12 +0000
commit17d34da9efab1e515b29755811b7ad7597aacb79 (patch)
tree7c5db433ad7eab8c82f58a452a879e4940735986 /tests/CMakeLists.txt
parent6a71bb538dd67a38b321b5f2066784afd26e8c22 (diff)
downloadarmnn-17d34da9efab1e515b29755811b7ad7597aacb79.tar.gz
Add addition timing logging output
* Adds ExecuteNetwork when building the delegate only * Adds timings to delegate subgraph creation * Adds executions times Signed-off-by: Jan Eilers <jan.eilers@arm.com> Change-Id: Ieff2f67ea8dbb6c2a708f8810e84a20485b7a631
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index cea55c5b8e..4cb324f2c7 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -133,7 +133,11 @@ if (BUILD_ONNX_PARSER)
OnnxParserTest(OnnxMobileNet-Armnn "${OnnxMobileNet-Armnn_sources}")
endif()
-if (BUILD_ARMNN_SERIALIZER OR BUILD_TF_PARSER OR BUILD_TF_LITE_PARSER OR BUILD_ONNX_PARSER)
+if (BUILD_ARMNN_SERIALIZER
+ OR BUILD_TF_PARSER
+ OR BUILD_TF_LITE_PARSER
+ OR BUILD_ONNX_PARSER
+ OR BUILD_ARMNN_TFLITE_DELEGATE)
set(ExecuteNetwork_sources
ExecuteNetwork/ExecuteNetwork.cpp
ExecuteNetwork/ExecuteNetworkProgramOptions.cpp