aboutsummaryrefslogtreecommitdiff
path: root/src/backends/reference/workloads/CMakeLists.txt
diff options
context:
space:
mode:
authorInki Dae <inki.dae@samsung.com>2020-09-10 15:33:54 +0900
committermike.kelly <mike.kelly@arm.com>2020-09-24 16:03:00 +0000
commitd4619e28a4cde423d5b4086a98c31f97b52a68d7 (patch)
tree9e6da174b200e8135ed2bbc2b0b8cb761d3e1a4f /src/backends/reference/workloads/CMakeLists.txt
parent02036e99c1b2074e5e5f04a2fe443f0c90689683 (diff)
downloadarmnn-d4619e28a4cde423d5b4086a98c31f97b52a68d7.tar.gz
Add int32 and int64 ArgMax op support
This patch adds int32 and int64 ArgMax op support. Current ARMNN already has ArgMax op but not used, and it doesn't support int64 output type. So this patch adds a new type, Signed64, and also adds ArgMinMax computation function for int64 type support. In default, output tensor type of ArgMax op is int64 in case of tensorflow lite model so this patch makes a proper function - ArgMax op for int64 or int32 - to be called according to parsed output_type value. With this patch, ARMNN supports both types - int64 and int32 - for ArgMinMax op. Changelog v1: - Check if output data type of ArgMinMax op is valid or not. - Use template function to support int32 and int64 types of ArgMinMax function. - Keep using Signed32 as default data type of m_Output_Type. Change-Id: I7a8e7e38dd9e5acc81464571d8b4d51378fc7f14 Signed-off-by: Inki Dae <inki.dae@samsung.com>
Diffstat (limited to 'src/backends/reference/workloads/CMakeLists.txt')
-rw-r--r--src/backends/reference/workloads/CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/src/backends/reference/workloads/CMakeLists.txt b/src/backends/reference/workloads/CMakeLists.txt
index 937a32029e..cd9efc96af 100644
--- a/src/backends/reference/workloads/CMakeLists.txt
+++ b/src/backends/reference/workloads/CMakeLists.txt
@@ -5,8 +5,6 @@
list(APPEND armnnRefBackendWorkloads_sources
Abs.hpp
- ArgMinMax.cpp
- ArgMinMax.hpp
Activation.cpp
Activation.hpp
ArgMinMax.cpp