aboutsummaryrefslogtreecommitdiff
path: root/src/backends/dynamic/reference/CMakeLists.txt
diff options
context:
space:
mode:
authorMatteo Martincigh <matteo.martincigh@arm.com>2019-08-14 14:05:46 +0100
committerMatteo Martincigh <matteo.martincigh@arm.com>2019-08-22 17:30:13 +0100
commite67edb238a3304dd767a34eca484d84bfebf76f5 (patch)
treefb0b7f1c13c7234c77e85953b4a9f6d4a0602617 /src/backends/dynamic/reference/CMakeLists.txt
parentc33882d1369927ad02f665b273af129c89834229 (diff)
downloadarmnn-e67edb238a3304dd767a34eca484d84bfebf76f5.tar.gz
IVGCVSW-3656 Make the reference backend optional
* Made the build of the reference backend depend on a new ARMCOMPUTEREF macro * Made the relevant targets dependent on the ref backend * Moved Cl and Neon static registry initializers to separate files * Wrapped some of the unit tests into proper ifdefs where necessary Change-Id: I7f2c42699682630233a4c4b6aed2f005083de189 Signed-off-by: Matteo Martincigh <matteo.martincigh@arm.com>
Diffstat (limited to 'src/backends/dynamic/reference/CMakeLists.txt')
-rw-r--r--src/backends/dynamic/reference/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/backends/dynamic/reference/CMakeLists.txt b/src/backends/dynamic/reference/CMakeLists.txt
index e9a94af2fc..6c040ecc81 100644
--- a/src/backends/dynamic/reference/CMakeLists.txt
+++ b/src/backends/dynamic/reference/CMakeLists.txt
@@ -14,7 +14,8 @@ set(RefBackendPath ${PROJECT_SOURCE_DIR}/src/backends/reference)
# Source files of the backend, taken directly from the source tree
file(GLOB RefBackendBaseFiles ${RefBackendPath}/*.cpp)
-set(RefBackendFiles ${RefBackendBaseFiles})
+file(GLOB RefBackendWorloadFiles ${RefBackendPath}/workloads/*.cpp)
+set(RefBackendFiles ${RefBackendBaseFiles} ${RefBackendWorloadFiles})
# Remove the file that contains the static backend registration
list(REMOVE_ITEM RefBackendFiles ${RefBackendPath}/RefRegistryInitializer.cpp)