aboutsummaryrefslogtreecommitdiff
path: root/src/backends/cl/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Monahan <David.Monahan@arm.com>2021-11-04 16:31:46 +0000
committerTeresaARM <teresa.charlinreyes@arm.com>2021-11-05 17:23:24 +0000
commit6642b8a1f23c5f7333abf1133983eb3134af7c00 (patch)
tree01a37677720ee4e959367f53b7873322721adbba /src/backends/cl/CMakeLists.txt
parent0f13284d702b3a37f56ffce1412867b5ad9eda89 (diff)
downloadarmnn-6642b8a1f23c5f7333abf1133983eb3134af7c00.tar.gz
IVGCVSW-6412 Implement CLBackend ICustomAllocator
* Added implementation of ClBackendDefaultAllocator * Added back in some pure virtual functions that were mistakenly removed from the CustomMemoryAllocatorSample * Added a new Gralloc MemorySource for memory which originates from the gpu * Added unittests Signed-off-by: David Monahan <David.Monahan@arm.com> Change-Id: Id2abb33d82697df36426f5709756c616af3e8ed7
Diffstat (limited to 'src/backends/cl/CMakeLists.txt')
-rw-r--r--src/backends/cl/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/backends/cl/CMakeLists.txt b/src/backends/cl/CMakeLists.txt
index 0005c8178b..3fef51cdcd 100644
--- a/src/backends/cl/CMakeLists.txt
+++ b/src/backends/cl/CMakeLists.txt
@@ -23,6 +23,7 @@ if(ARMCOMPUTECL)
ClBackend.hpp
ClBackendContext.cpp
ClBackendContext.hpp
+ ClBackendDefaultAllocator.hpp
ClBackendId.hpp
ClBackendModelContext.cpp
ClBackendModelContext.hpp