aboutsummaryrefslogtreecommitdiff
path: root/include/armnn/backends/CMakeLists.txt
diff options
context:
space:
mode:
authorColm Donelan <Colm.Donelan@arm.com>2020-01-29 15:22:43 +0000
committerColm Donelan <Colm.Donelan@arm.com>2020-01-29 16:23:48 +0000
commite49755b914a2c8f6f8b836adfcc61bf8f9a5b3a3 (patch)
tree98ad93e75c783e6552fdeda6206a84937181bb27 /include/armnn/backends/CMakeLists.txt
parent1426a3f52854d0d9457109c5f806bffde037bd34 (diff)
downloadarmnn-e49755b914a2c8f6f8b836adfcc61bf8f9a5b3a3.tar.gz
IVGCVSW-4316 First draft of IBackendProfiling and IBackendProfilingContext
* Introduce two new backend profiling interfaces IBackendProfiling and IBackendProfilingContext. * Add a mechanism to pull a context from a backend through IBackendInternal * Update CL, Neon and Ref backends to return an empty profiling backend. Signed-off-by: Colm Donelan <Colm.Donelan@arm.com> Change-Id: I6e7438fcb126ad7a073a226862dc44836c9998b7
Diffstat (limited to 'include/armnn/backends/CMakeLists.txt')
-rw-r--r--include/armnn/backends/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/armnn/backends/CMakeLists.txt b/include/armnn/backends/CMakeLists.txt
index 258ea8b9f9..90a022aad7 100644
--- a/include/armnn/backends/CMakeLists.txt
+++ b/include/armnn/backends/CMakeLists.txt
@@ -12,6 +12,8 @@ list(APPEND armnnBackendsAPI_sources
IMemoryManager.hpp
ITensorHandle.hpp
OptimizationViews.hpp
+ profiling/IBackendProfiling.hpp
+ profiling/IBackendProfilingContext.hpp
)
add_library(armnnBackendsAPI OBJECT ${armnnBackendsAPI_sources})