aboutsummaryrefslogtreecommitdiff
path: root/delegate/opaque/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthew Sloyan <matthew.sloyan@arm.com>2023-04-24 12:53:04 +0100
committerMatthew Sloyan <matthew.sloyan@arm.com>2023-04-24 18:03:44 +0100
commit080ffd84eccb4b849c192155c0ba39431d53c894 (patch)
treeb6ef09a3c5139ff900f627fc45d665c7e78401b9 /delegate/opaque/CMakeLists.txt
parent1ffbaac882792f166357ecf388667e8405c69966 (diff)
downloadarmnn-080ffd84eccb4b849c192155c0ba39431d53c894.tar.gz
IVGCVSW-7584 Implement Conv2d and DepthwiseConv2d operators for Opaque Delegate
* Added VisitConvolution2d and VisitDepthwiseConv2d functions to Convolution2d.hpp. * Enabled Convolution2d and DepthwiseConv2d tests. * Moved TransposeConvolution2d tests to separate file. * Added Opaque Delegate shared functions. Signed-off-by: Matthew Sloyan <matthew.sloyan@arm.com> Change-Id: Ica10c9469fc830f512edad1ad79884f90ae511d0
Diffstat (limited to 'delegate/opaque/CMakeLists.txt')
-rw-r--r--delegate/opaque/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/delegate/opaque/CMakeLists.txt b/delegate/opaque/CMakeLists.txt
index 1999299390..39df124310 100644
--- a/delegate/opaque/CMakeLists.txt
+++ b/delegate/opaque/CMakeLists.txt
@@ -8,7 +8,10 @@ list(APPEND armnnOpaqueDelegateObject_sources
include/armnn_delegate.hpp
include/Version.hpp
src/armnn_delegate.cpp
- src/Redefine.hpp)
+ src/Convolution.hpp
+ src/Redefine.hpp
+ src/SharedFunctions.cpp
+ src/SharedFunctions.hpp)
add_library(armnnOpaqueDelegateObject OBJECT ${armnnOpaqueDelegateObject_sources})