aboutsummaryrefslogtreecommitdiff
path: root/delegate/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthew Sloyan <matthew.sloyan@arm.com>2020-11-26 10:54:22 +0000
committerMatthew Sloyan <matthew.sloyan@arm.com>2020-12-07 09:41:42 +0000
commitc8eb955a2c9f0b432fe932e2df8445f242080e31 (patch)
treecb3a74ae4d3a2a558f0589a45a6d1ea6d58e02c3 /delegate/CMakeLists.txt
parent97451b4429b717f6ff19c10716d1d82a2ff6f155 (diff)
downloadarmnn-c8eb955a2c9f0b432fe932e2df8445f242080e31.tar.gz
IVGCVSW-5381 TfLiteDelegate: Implement the Logical operators
* Implemented Logical AND, NOT and OR operators. * NOT uses existing ElementwiseUnary VisitLayer function & tests. * AND/OR uses new LogicalBinary VisitLayer function & tests. Signed-off-by: Matthew Sloyan <matthew.sloyan@arm.com> Change-Id: I5e7f1e78b30c36ac7f14c70a712b54f98d664b83
Diffstat (limited to 'delegate/CMakeLists.txt')
-rw-r--r--delegate/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/delegate/CMakeLists.txt b/delegate/CMakeLists.txt
index aa2f3600bf..5303d81d26 100644
--- a/delegate/CMakeLists.txt
+++ b/delegate/CMakeLists.txt
@@ -28,6 +28,7 @@ list(APPEND armnnDelegate_sources
src/Fill.hpp
src/FullyConnected.hpp
src/Gather.hpp
+ src/LogicalBinary.hpp
src/Lstm.hpp
src/Normalization.hpp
src/Pad.hpp
@@ -114,6 +115,8 @@ if(BUILD_UNIT_TESTS)
src/test/FullyConnectedTestHelper.hpp
src/test/GatherTest.cpp
src/test/GatherTestHelper.hpp
+ src/test/LogicalTest.cpp
+ src/test/LogicalTestHelper.hpp
src/test/Pooling2dTest.cpp
src/test/Pooling2dTestHelper.hpp
src/test/QuantizationTest.cpp