aboutsummaryrefslogtreecommitdiff
path: root/delegate/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthew Sloyan <matthew.sloyan@arm.com>2021-02-03 10:43:04 +0000
committerFrancis Murtagh <francis.murtagh@arm.com>2021-02-08 16:25:54 +0000
commitac001eebca101f2df4973d2f1d8cfca026e07419 (patch)
treed8f3b0203a279e777fd27fd33a50282cd5adbc0f /delegate/CMakeLists.txt
parentd92a6e4c19567cb03de76963068c002353cea528 (diff)
downloadarmnn-ac001eebca101f2df4973d2f1d8cfca026e07419.tar.gz
IVGCVSW-4901 Add semantic versioning to Parsers and TfLite Delegate
* Added Version.hpp to all Parsers * Added Version.hpp to TfLite Delegate * Updated CMakeLists to use new versions * Added GetVersion method to parsers and TfLite Delegate Signed-off-by: Matthew Sloyan <matthew.sloyan@arm.com> Change-Id: If29e1e6d9e615f9095ec1c01ad47acfff40b1dd5
Diffstat (limited to 'delegate/CMakeLists.txt')
-rw-r--r--delegate/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/delegate/CMakeLists.txt b/delegate/CMakeLists.txt
index eda5b935e3..777702e0b4 100644
--- a/delegate/CMakeLists.txt
+++ b/delegate/CMakeLists.txt
@@ -14,6 +14,7 @@ set(armnnDelegate_sources)
list(APPEND armnnDelegate_sources
include/armnn_delegate.hpp
include/DelegateOptions.hpp
+ include/Version.hpp
src/armnn_delegate.cpp
src/armnn_external_delegate.cpp
src/DelegateOptions.cpp
@@ -103,6 +104,8 @@ target_include_directories(thirdparty_headers INTERFACE $<BUILD_INTERFACE:${ARMN
target_compile_options(thirdparty_headers INTERFACE -Wno-old-style-cast)
+set_target_properties(armnnDelegate PROPERTIES VERSION ${DELEGATE_LIB_VERSION} SOVERSION ${DELEGATE_LIB_SOVERSION})
+
option(BUILD_UNIT_TESTS "Build unit tests" ON)
if(BUILD_UNIT_TESTS)
set(armnnDelegate_unittest_sources)