aboutsummaryrefslogtreecommitdiff
path: root/delegate/CMakeLists.txt
diff options
context:
space:
mode:
authorJan Eilers <jan.eilers@arm.com>2020-12-15 10:42:38 +0000
committerJim Flynn <jim.flynn@arm.com>2021-01-22 11:48:34 +0000
commit2cd184763ff7f8767e751f2fe0c461714350aae6 (patch)
tree048a95b2b571bfa3ad03eceb5dd4ccd4d0a70c06 /delegate/CMakeLists.txt
parentd672f5d4386dc0545d2e484ce85b76d53edb6bc9 (diff)
downloadarmnn-2cd184763ff7f8767e751f2fe0c461714350aae6.tar.gz
IVGCVSW-5571 Expose the TfLite Delegate to the TfLite python API
* Implemented external delegate adaptor interface for TfLite * Activated armnn logging for delegate * Added logging info to indicate if gpu tuning is turned on * Added pytests to ensure functionality of the external delegate adaptor * Included the delegate directory into doxygen * Added documentation on how to use the external delegate in python Signed-off-by: Finn Williams <Finn.Williams@arm.com> Signed-off-by: Jan Eilers <jan.eilers@arm.com> Change-Id: Id3b4588fb0b9ac7e3f47ba2c19feead7beb58e18
Diffstat (limited to 'delegate/CMakeLists.txt')
-rw-r--r--delegate/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/delegate/CMakeLists.txt b/delegate/CMakeLists.txt
index 8383722628..495c1e3d77 100644
--- a/delegate/CMakeLists.txt
+++ b/delegate/CMakeLists.txt
@@ -15,6 +15,7 @@ list(APPEND armnnDelegate_sources
include/armnn_delegate.hpp
include/DelegateOptions.hpp
src/armnn_delegate.cpp
+ src/armnn_external_delegate.cpp
src/DelegateOptions.cpp
src/Activation.hpp
src/ArgMinMax.hpp